Prozilla – Linux Download Accelerator

Prozilla Download Accelerator is a multi-threaded download accelerator for Linux which supports both HTTP and FTP protocols and because it makes multiple connections to the server and downloads the file in portions, thus giving a much better speed rate than the conventional download programs which use a single connection, increases download speeds with up to 200-300%.

Resuming connections is fully supported and customizable.

Because it based on ncurses, Prozilla is also a lightweight download accelerator.

1. Get prozilla 2.0.4.

git clone https://github.com/totosugito/prozilla-2.0.4.git

2. Install required packages

apt-get install autoconf build-essential libncurses5-dev

3. Installing from source code

cd prozilla-2.0.4
./configure
make
make install

4. Troubleshouting. If an error occurs:

make[4]: Leaving directory `/home/user/prozilla-2.0.4/libprozilla/src’
make[4]: Entering directory `/home/user/prozilla-2.0.4/libprozilla’
make[4]: Nothing to be done for `all-am’.
make[4]: Leaving directory `/home/user/prozilla-2.0.4/libprozilla’
make[3]: Leaving directory `/home/user/prozilla-2.0.4/libprozilla’
make[2]: Leaving directory `/home/user/prozilla-2.0.4/libprozilla’
Making all in src
make[2]: Entering directory `/home/user/prozilla-2.0.4/src’
if g++ -DHAVE_CONFIG_H -I. -I. -I.. -I. -I.. -I../libprozilla/src -I../intl -I/usr/local/include -fno-inline -DLOCALEDIR=\”/usr/local/share/locale\” -Wall -ggdb -D_REENTRANT -MT main.o -MD -MP -MF “.deps/main.Tpo” \
-c -o main.o `test -f ‘main.cpp’ || echo ‘./’`main.cpp; \
then mv -f “.deps/main.Tpo” “.deps/main.Po”; \
else rm -f “.deps/main.Tpo”; exit 1; \
fi
In file included from main.cpp:39:
download_win.h:55: error: extra qualification ‘DL_Window::’ on member âprint_status’
make[2]: *** [main.o] Error 1
make[2]: Leaving directory `/home/user/prozilla-2.0.4/src’
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/home/user/prozilla-2.0.4′
make: *** [all] Error 2

And the solutions...

Looks like the problem of error occurs because the compatibility of the compiler the GNU C/C+ + latest version, to avoid this error edit the file src/download_win.h and replace:

void DL_Window::print_status(download_t * download, int quiet_mode);

with:

void print_status(download_t * download, int quiet_mode);

5. Do you want to make this a deb package?

apt-get install build-essential automake autoconf libtool pkg-config libcurl4-openssl-dev intltool libxml2-dev libgtk2.0-dev libnotify-dev libglib2.0-dev libevent-dev checkinstall
./configure && make && sudo checkinstall

 

5 thoughts on “Prozilla – Linux Download Accelerator”

  1. i can not follow your tutor, please help me…in the “make” proses i am failed to fix please help me
    this is said make[2]: Leaving directory `/root/prozilla-2.0.4/po’
    Making install in libprozilla
    make[2]: Entering directory `/root/prozilla-2.0.4/libprozilla’
    cd . && /root/prozilla-2.0.4/libprozilla/missing aclocal-1.4
    WARNING: `aclocal-1.4′ is needed, and you do not seem to have it handy on your
    system. You might have modified some files without having the
    proper tools for further handling them. Check the `README’ file,
    it often tells you about the needed prerequirements for installing
    this package. You may also peek at any GNU archive site, in case
    some other package would contain this missing `aclocal-1.4′ program.
    make[2]: *** [aclocal.m4] Error 1
    make[2]: Leaving directory `/root/prozilla-2.0.4/libprozilla’
    make[1]: *** [install-recursive] Error 1
    make[1]: Leaving directory `/root/prozilla-2.0.4′
    make: *** [install-strip] Error 2

  2. I have wrote a script involving a download part using prozilla download accelerator, but in each cycle, prozilla asks me “Previous download of gfs.t00z.pgrb2.0p50.f039 exists, would you like to (R)esume it or (O)verwrite it?” I dont want prozilla to ask me this but I want it to overwrite the existing file automatically. please help me sovle this problem. thanks all

Leave a Reply

Your email address will not be published. Required fields are marked *